POJ 2352 Stars 树状数组

Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 40175   Accepted: 17446

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 
POJ 2352 Stars 树状数组_第1张图片
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999


点击题目打开链接POJ2352

题目大意:

在坐标系上有n个星星,如果某个星星坐标为(x, y), 它的左下位置为:(x0,y0),x0<=x 且y0<=y。如果左下位置有a个星星,就表示这个星星属于level a

按照y递增,如果y相同则x递增的顺序给出n个星星,求出所有level水平的数量。


分析与总结:

因为输入是按照按照y递增,如果y相同则x递增的顺序给出的, 所以,对于第i颗星星,它的 level 就是之前出现过的星星中,横坐标x小于等于i星横坐标的那些星星的总数量(前面的y一定小于等于后面的y)。

所以,需要找到一种数据结构来记录所有星星的x值,方便的求出所有值为0~x的星星总数量。

树状数组和线段树都是很适合处理这种问题,这里先用树状数组解决,线段树解决见代码下面。

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

const int MAXN = 32000 + 10;
int C[MAXN], level[MAXN];

int N, X, Y;
//x 的二进制表达式中最右边的1所对应的值
int lowbit(int x)
{
    return x & -x;
}
//前缀和Sx
int sum(int x)
{
    int ret = 0;
    while(x > 0)        //在树状数组中向左上累加
    {
        ret += C[x];
        x -= lowbit(x);
    }
    return ret;
}
//更新树状数组
void add(int x, int d)
{
    while (x <= MAXN)   //在树状数组中向右下更新
    {
        C[x] += d;
        x += lowbit(x);
    }
}

int main()
{
    scanf("%d", &N);
    for(int i = 0; i < N; i++)
    {
        scanf("%d%d", &X, &Y);
        X += 1;             //坐标可能为0,而树状数组从1开始,故加一
        add(X, 1);          //更新
        level[sum(X) - 1]++;    //记录水平
    }
    for (int i = 0; i < N; i++)
        printf("%d\n", level[i]);
    return 0;
}
点击打开博客链接线段树解决

你可能感兴趣的:(ACM,树状数组)