暑假集训第三周周六赛 搜索 B - Red and Black红黑瓷片


B - Red and Black
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  HDU 1312

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input

      
      
      
      
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output

      
      
      
      
45 59 6 13
分析:

典型的DFS,就是有四个方向可以走,根据他们的坐标变化去处理他的步数变化

最重要的是要注意边界问题,处理好这个,就没有什么大问题了

多做几道这样的题,理解递归,分析出在哪里输出数据

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
#include<stdio.h>
int m,n,s;
char a[25][25];
int b[4]= {1,0,-1,0},c[4]= {0,1,0,-1};
void DFS(int i,int j)
{
    if(i<0||j<0 || i >= m || j >= n)
        return ;
    if(a[i][j]=='.')
    {
        a[i][j]='#';
        s++;
        for(int k=0; k<4; k++)
            DFS(i+b[k],j+c[k]);
    }
}
int main()
{
    int i,j;
    while(scanf("%d %d",&n,&m)&&m+n)
    {
        s=0;
        for(i=0; i<m; i++)
            scanf("%s",a[i]);
        for(i=0; i<m; i++)
            for(j=0; j<n; j++)
                if(a[i][j]=='@')
                {
                    a[i][j]='.';
                    DFS(i,j);
                }
        printf("%d\n",s);
    }
    return 0;
}


你可能感兴趣的:(深搜)