hdu 1018 Big Number

Big Number 

题目描述

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

输入

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.

输出

The output contains the number of digits in the factorial of the integers appearing in the input.

样例输入

2
10
20

样例输出

7
19


思路:斯特林公式:lnN!=NlnN-N+0.5*ln(2*N*pi),而N!的位数等于log(N!)+1


#include<stdio.h>
#include<math.h>
int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--){
		double s=0;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
			s+=log10(double(i));
		printf("%d\n",(int)s+1);		
	}
	return 0;
}



另一种方法(借鉴他人的代码)

#include<stdio.h>
#include<math.h>
#define p 3.14159265
#define e 2.71828182
int main()
{
	int n,m;
	scanf("%d",&n);
	while(n--){
		double s;
		scanf("%d",&m);
		s=log10(2*p*m)/2+m*log10(m/e);
		printf("%d\n",(int)s+1);
	}
	return 0;
}




你可能感兴趣的:(HDU)