南邮 OJ 1524 Optimal Parking

Optimal Parking

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 23            测试通过 : 21 

比赛描述

When shopping on Long Street, Michael usually parks his car at
some random location, and then walks to the stores he needs.
Can you help Michael choose a place to park which minimises
the distance he needs to walk on his shopping round?
Long Street is a straight line, where all positions are integer.
You pay for parking in a specific slot, which is an integer position
on Long Street. Michael does not want to pay for more than one
parking though. He is very strong, and does not mind carrying
all the bags around.



输入

The first line of input gives the number of test cases, 1 ≤ ≤ 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 ≤ ≤ 20, and the second gives their integer positions on Long Street, 0 ≤ x≤ 99.

输出

Output for each test case a line with the minimal distance Michael must walk given
optimal parking.

样例输入

24
24 13 89 37
6
7 30 41 14 39 42

样例输出

152
70

提示

undefined

题目来源

Nordic Collegiate Programming Contest 2007




#include<stdio.h>
int main(){
	int t,n,num,maxNum,minNum;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		maxNum = 0;
		minNum = 100;
		while(n--){
			scanf("%d",&num);
			if(maxNum<num){
				maxNum = num;
			}
			if(minNum>num){
				minNum = num;
			}
		}
		printf("%d\n",(maxNum-minNum)<<1);
	}
}



你可能感兴趣的:(ACM,Optimal,Parking,南邮OJ)