CodeForces 630 F. Selection of Personnel(组合数学)

Description
某公司准备从n名员工中选取5~7个人组成精英小组,问有多少种组队方案
Input
一个整数n表示员工个数(7<=n<=777)
Output
输出组队方案数
Sample Input
7
Sample Output
29
Solution
简单组合题,ans=C(n,5)+C(n,6)+C(n,7)
Code

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
int n;
ll C(int n,int m)
{
    if(n-m>m)m=n-m;
    ll ans=1ll;
    for(int i=1;i<=n-m;i++) 
        ans=ans*(m+i)/i;
    return ans;
}
int main()
{
    while(~scanf("%d",&n))
        printf("%I64d\n",C(n,5)+C(n,6)+C(n,7));
    return 0;
}

你可能感兴趣的:(CodeForces 630 F. Selection of Personnel(组合数学))