Eight
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14009 Accepted Submission(s): 3965
Special Judge
Problem Description
The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
1 2 3 4
5 6 7 8
9 10 11 12
13 14 15 x
where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4
5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->
The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.
Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).
In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle
1 2 3
x 4 6
7 5 8
is described by this list:
1 2 3 x 4 6 7 5 8
Output
You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
Sample Input
Sample Output
八数码问题。
BFS+康拓展开
#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#define N 400000
using namespace std;
struct node
{
int pos,val;
char a[9];
string path;
}cur,now;
int f[15]= {40320,5040,720,120,24,6,2,1,1}; //康拖展开判重
int dx[4]={-1,1,0,0};//上 下 左 右
int dy[4]={0,0,-1,1};
char dir[5]="durl";
string anspath[N],ans;
int vis[N];
char c;
queue<node>q;
int kanto(char *ss)
{
int ans=0;
int num;
for(int i=0;i<9;i++)
{
num=0;
for(int j=i+1;j<9;j++)
{
if(ss[i]>ss[j]) num++;
}
ans+=num*f[i];
}
return ans+1;
}
void bfs()
{
int x,y,t,t1,tempv;
char temps[9];
memset(vis,0,sizeof vis);
while(!q.empty())q.pop();
for(int i=0;i<8;i++)
cur.a[i]=i+1-0+'0';
cur.a[8]='0';
cur.pos=9;
cur.path="";
cur.val=kanto(cur.a);
vis[cur.val]=1;
anspath[cur.val]=cur.path;
q.push(cur);
while(!q.empty())
{
now=q.front();
t=now.pos;
y=t%3;
if(y==0) y=3;
x=(t-y)/3+1;
q.pop();
int nx,ny;
for(int i=0;i<4;i++)
{
nx=x+dx[i];
ny=y+dy[i];//眼睛都看瞎了,才看到写成n=y=dy[i];(⊙o⊙)…
t1=(nx-1)*3+ny;
memcpy(temps,now.a,sizeof(temps));
temps[t-1]=now.a[t1-1]; //模拟移动
temps[t1-1]='0';
tempv=kanto(temps);
if(nx>=1 && nx<=3 && ny>=1 && ny<=3 && !vis[tempv])
{
vis[tempv]=1;
cur.pos=t1;
cur.path=now.path+dir[i];
memcpy(cur.a,temps,sizeof(temps));
cur.val=tempv;
q.push(cur);
anspath[cur.val]=cur.path;
}
}
}
}
int main()
{
// f[0]=1;
// for(int i=1;i<9;i++)
// f[i]=f[i-1]*i;
bfs();
while(cin>>c)
{
if(c=='x')
{
cur.pos=1;
cur.a[0]='0';
}
else
cur.a[0]=c;
for(int i=1;i<9;i++)
{
cin>>c;
if(c=='x')
{
cur.pos=i+1;
cur.a[i]='0';
}
else
cur.a[i]=c;
}
cur.val=kanto(cur.a);
int flag;
if(vis[cur.val])
{
flag=anspath[cur.val].length();
for(int i=flag-1;i>=0;i--)
printf("%c",anspath[cur.val][i]);
}
else
printf("unsolvable");
cout<<endl;
}
return 0;
}