hdu--1286(欧拉函数入门基础)

找新朋友

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10130    Accepted Submission(s): 5352


Problem Description
新年快到了,“猪头帮协会”准备搞一个聚会,已经知道现有会员N人,把会员从1到N编号,其中会长的号码是N号,凡是和会长是老朋友的,那么该会员的号码肯定和N有大于1的公约数,否则都是新朋友,现在会长想知道究竟有几个新朋友?请你编程序帮会长计算出来。
 

Input
第一行是测试数据的组数CN(Case number,1<CN<10000),接着有CN行正整数N(1<n<32768),表示会员人数。
 

Output
对于每一个N,输出一行新朋友的人数,这样共有CN行输出。
 

Sample Input
   
   
   
   
2 25608 24027
 

Sample Output
   
   
   
   
7680 16016
 

Author
SmallBeer(CML)
 

Source
杭电ACM集训队训练赛(VII)
 
代码如下:
#include<stdio.h>
#include<cmath>
int ef(int n){
	int k=n;
	int cnt=n;
	int i;
	for(i=2;i<=sqrt(k);i++){
		if(n%i==0){
			cnt-=cnt/i;
			while(n%i==0)n/=i;
		}
	}
	if(n>1)cnt-=cnt/n;
	return cnt;
}
int main(){
	int t,n;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		int count=ef(n);
		printf("%d\n",count);
	}
	return 0;
} 


你可能感兴趣的:(hdu--1286(欧拉函数入门基础))