hdu 1217 Arbitrage (BellmanFord 变形 判断是否存在正权回路)

Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3277    Accepted Submission(s): 1489


Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
 

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
 

Sample Input
   
   
   
   
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 

Sample Output
   
   
   
   
Case 1: Yes Case 2: No
 

Source
University of Ulm Local Contest 1996

思路:
BellmanFord 原来是求是否存在负权回路,现在变形为求是否存在正权回路,换个初始化就够了。
 
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#define maxn 35
using namespace std;

int n,m,ans;
double r;
double dist[maxn];
double city[maxn][maxn];
string s,s1,s2;
map<string,int>money;
struct Node
{
    int le,ri;
    double rate;
}edge[maxn*maxn];

void init()
{
    money.clear();
    memset(city,0,sizeof(city));
    memset(dist,0,sizeof(dist));
    dist[1]=1;
}
bool BellmanFord()
{
    int i,j;
    for(i=1;i<n;i++)
    {
        for(j=1;j<=m;j++)
        {
            if(dist[edge[j].ri]<dist[edge[j].le]*edge[j].rate) dist[edge[j].ri]=dist[edge[j].le]*edge[j].rate;
        }
    }
    for(j=1;j<=m;j++)
    {
        if(dist[edge[j].ri]<dist[edge[j].le]*edge[j].rate) return true ;
    }
    return false ;
}
int main()
{
    int i,j,t=0;
    while(scanf("%d",&n),n)
    {
        t++;
        init();
        for(i=1;i<=n;i++)
        {
            cin>>s;
            money[s]=i;
        }
        scanf("%d",&m);
        for(i=1;i<=m;i++)
        {
            cin>>s1>>r>>s2;
            edge[i].le=money[s1];
            edge[i].ri=money[s2];
            edge[i].rate=r;
        }
        printf("Case %d: ",t);
        if(BellmanFord()) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}



你可能感兴趣的:(hdu 1217 Arbitrage (BellmanFord 变形 判断是否存在正权回路))