Dividing
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6377 Accepted Submission(s): 1737
Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.
The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.
Output a blank line after each test case.
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
Sample Output
Collection #1:
Can't be divided.
Collection #2:
Can be divided.
Source
Mid-Central European Regional Contest 1999
Recommend
JGShining
Statistic | Submit | Discuss | Note
#include<iostream>
#include<stdio.h>
using namespace std;
int f[6*20000+10];
int a[7];
int v;
void init()
{
for(int i=1;i<=v;i++)
{
f[i]=-120000-1;
}
f[0]=0;
}
void zeroonepack(int cost,int value)
{
for(int i=v;i>=cost;i--)
{
f[i]=max(f[i],f[i-cost]+value);
}
}
void completepack(int cost,int value)
{
for(int i=cost;i<=v;i++)
{
f[i]=max(f[i],f[i-cost]+value);
}
}
void multiplypack(int cost ,int value ,int amount)
{
if(cost*amount>v)
{
completepack(cost,value);
return ;
}
int k=1;
while(k<amount)
{
zeroonepack(cost*k,value*k);
amount-=k;
k=k*2;
}
zeroonepack(cost*amount,value*amount);
}
int main()
{
int count=1;
while(1)
{
scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6]);
if((a[1]==0)&&(a[2]==0)&&(a[3]==0)&&(a[4]==0)&&(a[5]==0)&&(a[6]==0))break;
int sum=a[1]+a[2]*2+a[3]*3+a[4]*4+a[5]*5+a[6]*6;
if(sum%2==0)
{
v=sum/2;
init();
for(int i=1;i<=6;i++)
multiplypack(i,1,a[i]);
printf("Collection #%d:\n",count++);
if(f[v]<0)printf("Can't be divided.\n");
else printf("Can be divided.\n");
printf("\n");
}
else
{
printf("Collection #%d:\n",count++);
printf("Can't be divided.\n");
printf("\n");
}
}
return 0;
}
这是一个完全背包问题。只不过用另一种思路来解答。f [v] 代表的是当一个人获得的总价值为v的时候总共选了几个marble。如果最后f[v]有合理的值的时候就代表着
能够完成平均分配。在这里需要注意的是f数组的初始化f[0]应该初始化为0,其他的都应该初始化为负无穷。因为这里要求的是恰好达到v所要选的的marb个数。此时
只有选0个的时候达到的价值是0,其他的无论选几个都不是可行解,因此初始化为负无穷。。具体的我建议参照一下《背包问题九讲》