HDOJ 1017 A Mathematical Curiosity

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31697    Accepted Submission(s): 10152


Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
   
   
   
   
1 10 1 20 3 30 4 0 0
 

Sample Output
   
   
   
   
Case 1: 2 Case 2: 4 Case 3: 5
 

Source
East Central North America 1999, Practice
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1018  1016  1032  1061  1048

题目意思:简单枚举,求  0 < a < b < n    ,  (a^2+b^2 +m)/(ab) 能整除的情况

格式要求,格式是个坑:

第一行就是要测试数据的组数(就是那么多的数据作为一组)。 然后下边的数据就是每一小组要测试的数据 并且每一小组以0 0结束,每一行结果要换行,每一组要换行,其中最后一大组结束时不换行。否则,就会Presentation Error。我试过的。 3 10 1 2 5 3 3 6 8 0 0 2 9 3 7 0 0 6 6 5 4 9 8 0 0 这就表示有三大组,每组的测试数据个数不定,以 0 0 结束。 希望对后边的同志有所帮助

#include<stdio.h>
int main(){
	int k,n,m,t,i,j,sum;
	scanf("%d",&t);
	while(t--){
		k=0;
		while(scanf("%d%d",&n,&m),n||m){
			k++;
			sum=0;
			for(i=1;i<n-1;i++){
				for(j=i+1;j<n;j++){
					if((i*i+j*j+m)%(i*j)==0)
						sum++;
				}
			}
			printf("Case %d: %d\n",k,sum);
		}
		if(t) printf("\n");//格式
	}
	return 0;
}


你可能感兴趣的:(hdoj)