【杭电oj】1280 - 前m大的数(水)

前m大的数

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15329    Accepted Submission(s): 5221


Problem Description
还记得Gardon给小希布置的那个作业么?(上次比赛的1005)其实小希已经找回了原来的那张数表,现在她想确认一下她的答案是否正确,但是整个的答案是很庞大的表,小希只想让你把答案中最大的M个数告诉她就可以了。 
给定一个包含N(N<=3000)个正整数的序列,每个数不超过5000,对它们两两相加得到的N*(N-1)/2个和,求出其中前M大的数(M<=1000)并按从大到小的顺序排列。
 

Input
输入可能包含多组数据,其中每组数据包括两行: 
第一行两个数N和M, 
第二行N个数,表示该序列。

 

Output
对于输入的每组数据,输出M个数,表示结果。输出应当按照从大到小的顺序排列。
 

Sample Input
   
   
   
   
4 4 1 2 3 4 4 5 5 3 6 4
 

Sample Output
   
   
   
   
7 6 5 5 11 10 9 9 8
 

Author
Gardon
 

Source
杭电ACM集训队训练赛(VI)


也许是我没抓到关键的知识点吧,反正就是都列举出来,排序一下,然后输出就完了,感觉很水就过了。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[3000*1500+50];
bool cmp(int a,int b)
{
	return a>b;
}

int main()
{
	int num[3111];
	int n,m;
	while (~scanf ("%d %d",&n,&m))
	{
		for (int i=0;i<n;i++)
			scanf ("%d",&num[i]);
		int t = 0;
		for (int i=0;i<n-1;i++)
		{
			for (int j=i+1;j<n;j++)
			{
				a[t++] = num[i]+num[j];
			}
		}
		sort (a,a+t,cmp);
		for (int i=0;i<m-1;i++)
			printf ("%d ",a[i]);
		printf ("%d\n",a[m-1]);
	}
	return 0;
}


你可能感兴趣的:(【杭电oj】1280 - 前m大的数(水))