USCAO section1.2 Palindromic Squares

 
                                                     Palindromic Squares
   
    
Rob Kolstad 
   

Palindromes are numbers that read the same forwards as backwards. The number 12321 is a typical palindrome.

Given a number base B (2 <= B <= 20 base 10), print all the integers N (1 <= N <= 300 base 10) such that the square of N is palindromic when expressed in base B; also print the value of that palindromic square. Use the letters 'A', 'B', and so on to represent the digits 10, 11, and so on.

Print both the number and its square in base B.

PROGRAM NAME: palsquare

INPUT FORMAT

A single line with B, the base (specified in base 10).

SAMPLE INPUT (file palsquare.in)

10

OUTPUT FORMAT

Lines with two integers represented in base B. The first integer is the number whose square is palindromic; the second integer is the square itself.

SAMPLE OUTPUT (file palsquare.out)

1 1
2 4
3 9
11 121
22 484
26 676
101 10201
111 12321
121 14641
202 40804
212 44944
264 69696

 

回文判断处理,注意细节,还是蛮好A的,具体看代码,还是挺容易懂的吧(我这代码源先在写的时候就被我一哥们批的体无完肤,不过个人认为还好)

 

/*
ID:nealgav1
PROG:palsquare
LANG:C++
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 1234
using namespace std;
struct A
{
  int star[N];
  int sq[N];
  char s[N][102];
  char e[N][102];
  int shu;
};
const char b[22]={'0','1','2','3','4','5','6','7','8','9','A','B','C','D','E','F','G','H','I','J','K','L'};
struct A pa[30];
struct A help;
void creat()
{
  for(int i=1;i<=300;i++)
  {
    help.star[i]=i;
    help.sq[i]=i*i;
  }
}
void transfor(int n)
{

  for(int j=1;j<=300;j++)
  {
    int i=0;
    while(help.sq[j])
   {
    help.e[j][i++]=b[help.sq[j]%n];
    help.sq[j]/=n;
   }
   help.e[j][i]='\0';
   int ii=0;
    while(help.star[j])
    {
      help.s[j][ii++]=b[help.star[j]%n];
      help.star[j]/=n;
    }
    help.s[j][ii]='\0';
  }
}
void charge(int n)
{
  int l,r,k,len;
  bool flag;
  k=0;
  for(int j=1;j<=300;j++)
  {
    flag=0;

    len=strlen(help.e[j]);
    l=0;r=len-1;
    while(l<r)
    {
      if(help.e[j][l]==help.e[j][r])
      {
        l++;r--;
      }
      else
      {
        flag=1;
        break;
      }
    }
    if(!flag)
    {
      strcpy(pa[n].e[++k],help.e[j]);
      strcpy(pa[n].s[k],help.s[j]);
    }
  }
  pa[n].shu=k;
}
void ok()
{
  for(int i=2;i<=20;i++)
  {
    creat();
    transfor(i);
    charge(i);
  }
}
int main()
{
  int m;
  ok();
  freopen("palsquare.in","r",stdin);
  freopen("palsquare.out","w",stdout);
  while(scanf("%d",&m)!=EOF)
  {
    for(int i=1;i<=pa[m].shu;i++)
    {
      for(int j=strlen(pa[m].s[i])-1;j>=0;j--)
      printf("%c",pa[m].s[i][j]);
      printf(" %s\n",pa[m].e[i]);
    }
  }
}

 
USER: Neal Gavin Gavin [nealgav1]
TASK: palsquare
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.011 secs, 11264 KB]
   Test 2: TEST OK [0.011 secs, 11264 KB]
   Test 3: TEST OK [0.302 secs, 11264 KB]
   Test 4: TEST OK [0.000 secs, 11264 KB]
   Test 5: TEST OK [0.000 secs, 11264 KB]
   Test 6: TEST OK [0.011 secs, 11264 KB]
   Test 7: TEST OK [0.011 secs, 11264 KB]
   Test 8: TEST OK [0.011 secs, 11264 KB]

All tests OK.

YOUR PROGRAM ('palsquare') WORKED FIRST TIME! That's fantastic -- and a rare thing. Please accept these special automated congratulations.

Here are the test data inputs:

------- test 1 ----
10
------- test 2 ----
2
------- test 3 ----
5
------- test 4 ----
11
------- test 5 ----
15
------- test 6 ----
18
------- test 7 ----
20
------- test 8 ----
3
Keep up the good work!
Palindromic Squares
Russ Cox

We generate all the squares from 1 to 300 and check to see which are palindromes.

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <ctype.h>
#include <math.h>

/* is string s a palindrome? */
int
ispal(char *s)
{
    char *t;

    t = s+strlen(s)-1;
    for(t=s+strlen(s)-1; s<t; s++, t--)
    	if(*s != *t)
	    return 0;

    return 1;
}

/* put the base b representation of n into s: 0 is represented by "" */

void
numbconv(char *s, int n, int b)
{
    int len;

    if(n == 0) {
	strcpy(s, "");
	return;
    }

    /* figure out first n-1 digits */
    numbconv(s, n/b, b);

    /* add last digit */
    len = strlen(s);
    s[len] = "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ"[n%b];
    s[len+1] = '\0';
}

void
main(void)
{
    char s[20];
    char t[20];
    int i, base;
    FILE *fin, *fout;

    fin = fopen("palsquare.in", "r");
    fout = fopen("palsquare.out", "w");
    assert(fin != NULL && fout != NULL);

    fscanf(fin, "%d", &base);
    for(i=1; i <= 300; i++) {
	numbconv(s, i*i, base);
	if(ispal(s)) {
	    numbconv(t, i, base);
	    fprintf(fout, "%s %s\n", t, s);
	}
    }
    exit(0);
}

 Thanks for your submission! 
 

你可能感兴趣的:(struct,File,null,Integer,output,Numbers)