【CodeForces】609C - Load Balancing(水)

Load Balancing
Crawling in process... Crawling failed Time Limit:2000MS    Memory Limit:262144KB    64bit IO Format:%I64d & %I64u
Submit Status Practice CodeForces 609C

Description

In the school computer room there are n servers which are responsible for processing several computing tasks. You know the number of scheduled tasks for each server: there aremi tasks assigned to thei-th server.

In order to balance the load for each server, you want to reassign some tasks to make the difference between the most loaded server and the least loaded server as small as possible. In other words you want to minimize expressionma - mb, wherea is the most loaded server and b is the least loaded one.

In one second you can reassign a single task. Thus in one second you can choose any pair of servers and move a single task from one server to another.

Write a program to find the minimum number of seconds needed to balance the load of servers.

Input

The first line contains positive number n (1 ≤ n ≤ 105) — the number of the servers.

The second line contains the sequence of non-negative integers m1, m2, ..., mn (0 ≤ mi ≤ 2·104), where mi is the number of tasks assigned to thei-th server.

Output

Print the minimum number of seconds required to balance the load.

Sample Input

Input
2
1 6
Output
2
Input
7
10 11 10 11 10 11 11
Output
0
Input
5
1 2 3 4 5
Output
3

Sample Output

Hint

In the first example two seconds are needed. In each second, a single task from server #2 should be moved to server #1. After two seconds there should be 3 tasks on server #1 and 4 tasks on server #2.

In the second example the load is already balanced.

A possible sequence of task movements for the third example is:

  1. move a task from server #4 to server #1 (the sequence m becomes: 2 2 3 3 5);
  2. then move task from server #5 to server #1 (the sequence m becomes: 3 2 3 3 4);
  3. then move task from server #5 to server #2 (the sequence m becomes: 3 3 3 3 3).

The above sequence is one of several possible ways to balance the load of servers in three seconds.


代码如下:

#include <stdio.h>
int main()
{
	int m[200022];		//就是这里少了个0!!! 
	int u;
	long int sum;
	long int tar;
	long int ans;
	long int max;
	while (~scanf ("%d",&u))
	{
		sum=0;
		ans=0;
		for (int i=1;i<=u;i++)
		{
			scanf ("%d",&m[i]);
			sum+=m[i];
		}
		if (sum/u==(double)sum/(double)u)
		{
			tar=sum/u;
			for (int i=1;i<=u;i++)
			{
				if (m[i]<tar)
					ans+=(tar-m[i]);
			}
			printf ("%ld\n",ans);
		}
		else
		{
			tar=sum/u;
			max=tar+1;
			long int tans=0;
			for (int i=1;i<=u;i++)
			{
				if (m[i]<tar)
				{
					ans+=(tar-m[i]);
				}
				if (m[i]>max)
				{
					tans+=(m[i]-max);
				}
			}
			if (tans>ans)
				printf ("%ld\n",tans);
			else
				printf ("%ld\n",ans);
		}
	}
	return 0;
}


蓝鸟幸灾乐祸,鄙视!

你可能感兴趣的:(【CodeForces】609C - Load Balancing(水))