The shortest problem
Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 374 Accepted Submission(s): 183
Problem Description
In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.
Input
Multiple input.
We have two integer n (0<=n<=
104 ) , t(0<=t<=
105 ) in each row.
When n==-1 and t==-1 mean the end of input.
Output
For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.
Sample Input
Sample Output
Source
2015 Multi-University Training Contest 7
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long int LL;
int n,t;
int cnt(LL x)
{
int ret=0;
while(x) { ret+=x%10; x/=10; }
return ret;
}
int getE(LL x)
{
int e=0;
while(x) { e++; x/=10; }
return e;
}
int main()
{
int cas=1;
while(cin>>n>>t)
{
if(n==-1&&t==-1) break;
LL sig=n%11;
LL wei=cnt(n);
for(int i=1;i<=t;i++)
{
int k=getE(wei);
LL e=1;
for(int j=0;j<k;j++) e=e*10;
sig=(sig*e%11+wei)%11;
wei+=cnt(wei);
}
sig%=11;
printf("Case #%d: ",cas++);
if(sig==0) puts("Yes");
else puts("No");
}
return 0;
}