Hduoj1027【全排列】

/*Ignatius and the Princess II
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5721    Accepted Submission(s): 3372


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess.
But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, 
I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the 
smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once
in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. 
You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume 
that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should 
print a space between two numbers, but do not output any spaces after the last number.

Sample Input
6 4
11 8
 

Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
 

Author
Ignatius.L
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;
int f[1010];
int main()
{
	int i, j, k, n, m;
	while(scanf("%d%d", &n,&m) != EOF)
	{
		for(i = 0; i < n; ++i)
		f[i] = i+1;
		k = 1;
		while(next_permutation(f, f+n))
		{
			k++;
			if(k == m)
			break;
		}
		for(i = 0; i < n-1; ++i)
		printf("%d ", f[i]);
		printf("%d\n", f[n-1]); 
	}
	return 0;
} 

题意:题意就说给你一个1~n的排列,让你求全排列中的第n个排列。

你可能感兴趣的:(Hduoj1027【全排列】)