hdu 1075 What Are You Talking About

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 9527    Accepted Submission(s): 2975


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
   
   
   
   
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
   
   
   
   
hello, i'm from mars. i like earth!
Hint
Huge input, scanf is recommended.
#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<cmath>
#include<algorithm>
#include<map>
using namespace std;

int n,m;
string s1,s2,temp,sh,chas;
char s[3005],ch,sss[20];
map<string,string> dic;
map<string,string>::iterator iter;

void solve()
{
	int i,j,start,ender,len;
	len=strlen(s);
	for(i=0;i<len; )
	{
		while(!(s[i]<='z'&&s[i]>='a')&&s[i]!='\0')
		{
			putchar(s[i]);
			i++;
		}
		sh="";
		start=i;
		while(s[i]<='z'&&s[i]>='a')
		{
			sh+=s[i];
			i++;
		}
		ender=i-1;
		iter=dic.find(sh);
		if(iter!=dic.end())
		{
			chas=iter->second;
			cout<<chas;
		}
		else
		{
			for(j=start;j<=ender;j++)
				putchar(s[j]);
		}
	}
	cout<<endl;
}
int main()
{
	int i,j,t;
	cin>>temp;
	if(temp=="START")
	{
		while(1)
		{
			cin>>s1;
			if(s1=="END")  break;
			cin>>s2;
			dic[s2]=s1;  // 此处注意这样建map  因为查找只能查找s2 纠结了我好半天 ╮(╯▽╰)╭
		}
	}
//	for(iter=dic.begin();iter!=dic.end();iter++)   测试map的输出(按字典顺序)
//        cout<<iter->first<<"   "<<iter->second<<endl;
	cin>>temp;        
	if(temp=="START")
	{
	    getchar();  // 这里不加这行的话 后面的‘\n'会被gets(s)读入 然后多输出一组换行 PE
		while(1)
		{
			gets(s);
			if(strcmp(s,"END")==0)   break;
			else solve();
		}
	}
	return 0;
}


你可能感兴趣的:(hdu 1075 What Are You Talking About)