hdu4301(DP)

Divide Chocolate

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1480    Accepted Submission(s): 690


Problem Description
It is well known that claire likes dessert very much, especially chocolate. But as a girl she also focuses on the intake of calories each day. To satisfy both of the two desires, claire makes a decision that each chocolate should be divided into several parts, and each time she will enjoy only one part of the chocolate. Obviously clever claire can easily accomplish the division, but she is curious about how many ways there are to divide the chocolate.
hdu4301(DP)_第1张图片
To simplify this problem, the chocolate can be seen as a rectangular contains n*2 grids (see above). And for a legal division plan, each part contains one or more grids that are connected. We say two grids are connected only if they share an edge with each other or they are both connected with a third grid that belongs to the same part. And please note, because of the amazing craft, each grid is different with others, so symmetrical division methods should be seen as different.
 

Input
First line of the input contains one integer indicates the number of test cases. For each case, there is a single line containing two integers n (1<=n<=1000) and k (1<=k<=2*n).n denotes the size of the chocolate and k denotes the number of parts claire wants to divide it into.
 

Output
For each case please print the answer (the number of different ways to divide the chocolate) module 100000007 in a single line.�
 

Sample Input
   
   
   
   
2 2 1 5 2
 

Sample Output
   
   
   
   
1 45
 

Author
BUPT
 

Source
2012 Multi-University Training Contest 1
 

Recommend
zhuyuanchen520
 

本题是DP,任何DP题首先都得找出状态转移方程,即通常所说的规律。本题的规律其实并不难。

设dp[i][j][0]表示前i列分成k块且第i列不分开的种类数,dp[i][j][1]表示前i列分成k块且第i列分开的种类数。

     dp[i][j][0]=dp[i-1][j][0]+dp[i-1][j][1]*2+dp[i-1][j-1][0]+dp[i-1][j-1][1]

     dp[i][j][1]=dp[i-1][j][1]+dp[i-1][j-1][1]*2+dp[i-1][j-1][0]*2+dp[i-1][j-2][0]+dp[i-1][j-2][1]


 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int mod=100000007;
const int MAXN=1010;
int dp[MAXN][MAXN*2][2];


void init()
{
	int i,j;
	memset(dp,0,sizeof(dp));
	dp[1][1][0]=1;dp[1][2][1]=1;
	
	for(i=2; i<=1005; i++)
    {
        for(j=1; j<=i*2; j++)
        {
			dp[i][j][0]=(dp[i-1][j][0]+dp[i-1][j][1]*2+dp[i-1][j-1][0]+dp[i-1][j-1][1])%mod;
			dp[i][j][1]=(dp[i-1][j][1]+dp[i-1][j-1][1]*2+dp[i-1][j-1][0]*2+dp[i-1][j-2][0]+dp[i-1][j-2][1])%mod;
		}
	}
}

int main()
{
	int cas,n,k;
	init();
	cin>>cas;
	while(cas--)
	{
		scanf("%d%d",&n,&k);
		printf("%d\n",(dp[n][k][0]+dp[n][k][1])%mod);
	}
	return 0;
}


 

你可能感兴趣的:(动态规划)