poj 1650 Integer Approximation


  昨天看了这道题,先是一直Wrong,后来又Tl,把我郁闷惨了,今天在网上搜了一下,才AC了……哎,需要好好努力啊
Integer Approximation
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4550   Accepted: 1445

Description

The FORTH programming language does not support floating-point arithmetic at all. Its author, Chuck Moore, maintains that floating-point calculations are too slow and most of the time can be emulated by integers with proper scaling. For example, to calculate the area of the circle with the radius R he suggests to use formula like R * R * 355 / 113, which is in fact surprisingly accurate. The value of 355 / 113 ≈ 3.141593 is approximating the value of PI with the absolute error of only about 2*10 -7. You are to find the best integer approximation of a given floating-point number A within a given integer limit L. That is, to find such two integers N and D (1 <= N, D <= L) that the value of absolute error |A - N / D| is minimal.

Input

The first line of input contains a floating-point number A (0.1 <= A < 10) with the precision of up to 15 decimal digits. The second line contains the integer limit L. (1 <= L <= 100000).

Output

Output file must contain two integers, N and D, separated by space.

Sample Input

3.14159265358979 10000

Sample Output

355 113

Source

Northeastern Europe 2001, Far-Eastern Subregion

很简单,直接贴代码:
#include<stdio.h>
#include<math.h>
int main()
{
	int N, D, L;
	double A, min=9999, temp;
	scanf("%lf %d",&A, &L);
	int i=1,j=1;
	while(i<=L && j<=L)
	{
        temp=fabs(j*1.0/i-A);
        if(temp<min )
        {
            D=i;
            N=j;
            min=temp;
        }
        if(j*1.0/i>=A) i++;
        else if(j*1.0/i<=A) j++;
    }
	printf("%d %d\n",N,D);
}


你可能感兴趣的:(File,Integer,input,UP,output)