HDU 1874 畅通工程续

Problem Description

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

Input

本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。

Output

对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

Sample Input

3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2

Sample Output

2

-1

简单最短路

#include<stdio.h>
#include<string.h>
#include<vector>
#include<queue>
#include<functional>
using namespace std;
const int maxn = 10005;
int n, m, x, y, z, dis[maxn];

struct abc
{
    int next, v;
    abc(){};
    abc(int a, int b) :next(a), v(b){};
};

vector<abc> tree[maxn];

struct cmp
{
    bool operator ()(const int &a, const int &b)
    {
        return dis[a] > dis[b];
    }
};

int dijkstra(int begin, int end)
{
    priority_queue<int, vector<int>, cmp> p;
    memset(dis, -1, sizeof(dis));
    dis[begin] = 0;
    p.push(begin);
    while (!p.empty())
    {
        int q = p.top();    p.pop();
        for (int i = 0, j; i < tree[q].size(); i++)
        {
            j = tree[q][i].next;
            if (dis[j] == -1 || dis[j]> dis[q] + tree[q][i].v)
            {
                dis[j] = dis[q] + tree[q][i].v;
                p.push(j);
            }
        }
    }
    return dis[end];
}

int main()
{
    while (scanf("%d%d", &n, &m)!=EOF)
    {
        for (int i = 0; i <= n; i++) tree[i].clear();
        for (int i = 0; i < m; i++)
        {
            scanf("%d%d%d", &x, &y, &z);
            tree[x].push_back(abc(y, z));
            tree[y].push_back(abc(x, z));
        }
        scanf("%d%d", &x, &y);
        printf("%d\n", dijkstra(x, y));
    }
    return 0;
}


你可能感兴趣的:(HDU)