POJ 2661 Factstone Benchmark 斯特林(stirling公式)应用

http://poj.org/problem?id=2661

 

Factstone Benchmark
Time Limit: 1000MS   Memory Limit: 65536K

Description

Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.) 
Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word. 
Given a year 1960 <= y <= 2160, what will be the Factstone rating of Amtel's most recently released chip?

Input

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the Factstone rating.

Sample Input

1960
1981
0

Sample Output

3
8
由于这是高精度没法用普通方式计算阶乘,否则会TLE
可以用斯特林(Stirling)公式求解
   
   
   
   
斯特林( Stirling )公式:
/* Author : yan
 * Question : POJ 2661 Factstone Benchmark
 * Date && Time : Thursday, January 27 2011 11:50 PM
 * Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
#define PI 3.141592654
#define E 2.71828182846
int opt[205];
int main()
{
	//freopen("input","r",stdin);
	int i;
	int tmp;
	int cache;
	double log_n;
	double log_2=log(2);
	opt[0]=4;
	for(i=1;i<201;i++) opt[i]=opt[i-1]*2;
	while(scanf("%d",&tmp) && tmp)
	{
		//printf("%d/n",opt[(int)(tmp-1960)/10]);
		cache=opt[(int)(tmp-1960)/10];
		for(i=4;;i++)
		{
			log_n=0.5*log(2*PI*i)+i*log(i/E);
			if(log_n/log_2>cache)
			{
				printf("%d/n",i-1);
				break;
			}
		}
	}
	return 0;
}
 

 

你可能感兴趣的:(cache,ubuntu,Integer,input,compiler,output)