hdoj-1312-Red and Black

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
….#.
…..#
……
……
……
……
……

@…

.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..

.

…@…

.

..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

很水的dfs
一个人站在一块黑色瓷砖上,他只能前后左右的走,切不可以走到红色瓷砖上。求它可到达的瓷砖数。
DFS,每次标记后都不清空标记。
然后输入的时候要注意。我WA了三次都卡输入上了

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
    int map[22][22];  
    int w,h,max=INT_MIN;  
    int dx[]={-1,1,0,0},dy[]={0,0,-1,1};  

    void dfs(int x,int y)  
    {  
        int i;  
        for(i=0;i<4;i++)  
        {  
            if(!map[x+dx[i]][y+dy[i]]&&x+dx[i]<=h&&y+dy[i]<=w&&x+dx[i]>0&&y+dy[i]>0)  
            {  
                max++;  
                map[x+dx[i]][y+dy[i]]=1;  
                dfs(x+dx[i],y+dy[i]);  
            }  
        }  
    }  

    int main()  
    {  
        int i,j,x,y;  
        char c;  
        while(scanf("%d %d",&w,&h)&&(w||h))  
        {  

            max=0;  
            memset(map,0,sizeof(map));  
            for(i=1;i<=h;i++)  
            {  
                getchar();  
                for(j=1;j<=w;j++)  
                {  
                    scanf("%c",&c);  
                    if(c=='.')  
                        map[i][j]=0;  
                    else if(c=='#')  
                        map[i][j]=1;  
                    else if(c=='@')  
                    {  
                        map[i][j]=1;  
                        x=i;y=j;max=1;  
                    }  
                }  
            }  
            dfs(x,y);  
            printf("%d\n",max);  
        }  
        return 0;  
    }  

你可能感兴趣的:(hdoj-1312-Red and Black)