hdoj 3336 Count the string 【kmp求 所有前缀 在原串中出现的次数 总和】

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5636    Accepted Submission(s): 2654


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input
   
   
   
   
1 4 abab

Sample Output
   
   
   
   
6
由失配函数f[ ],可推出前i个字符构成的字符前缀 在原串中出现次数 dp[ i ] = dp[ f[i ] ] + 1
 
mp:93ms
 
#include <cstdio>
#include <cstring>
#define LL long long
#define MAX 200000+10
#define MOD 10007
using namespace std; 
char P[MAX], T[MAX];
int f[MAX];
LL dp[MAX];//存储前i个字符构成的字符串  在原串中出现的个数 
void getfail()
{
    int i, j;
    f[0] = f[1] = 0;
    int len = strlen(P);
    for(i = 1; i < len; i++)
    {
        j = f[i];
        while(j && P[i] != P[j])
        j = f[j];
        f[i+1] = P[i]==P[j]?j+1:0;
    }
}
int main()
{
    int t, n;
    int i, j;
    LL sum;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        scanf("%s", P);
        getfail();
        sum = 0;
        dp[0] = 0; 
        for(i = 1; i <= n; i++)
        {
            dp[i] = (dp[f[i]]%MOD + 1) % MOD;
            sum = (sum%MOD + dp[i]%MOD) % MOD; 
        }
        printf("%lld\n", sum);
    }
    return 0;
}

kmp:78ms
 
#include <cstdio>
#include <cstring>
#define MAX 200000+10
#define MOD 10007
#define LL long long
using namespace std;
char P[MAX];
int f[MAX];
LL dp[MAX];
void getfail()
{
    int i = 0, j = -1;
    int len = strlen(P);
    f[0] = -1;
    while(i < len)
    {
        if(j == -1 || P[i] == P[j])
        f[++i] = ++j;
        else
        j = f[j];
    }
}
int main()
{
    int t, n;
    LL sum;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        scanf("%s", P);
        getfail();
        sum = dp[0] = 0;
        for(int i = 1; i <= n; i++)
        {
            dp[i] = (dp[f[i]]%MOD + 1) % MOD;
            sum = (sum%MOD + dp[i]%MOD) % MOD;
        }
        printf("%lld\n", sum);
    }
    return 0;
}

 
 

你可能感兴趣的:(hdoj 3336 Count the string 【kmp求 所有前缀 在原串中出现的次数 总和】)