hdu 3018 欧拉回路

http://acm.hdu.edu.cn/showproblem.php?pid=3018



Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country. 

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
hdu 3018 欧拉回路_第1张图片
 

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
 

Output
For each test case ,output the least groups that needs to form to achieve their goal.
 

Sample Input
   
   
   
   
3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
   
   
   
   
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.
思路: 不存在奇度点,那么它需要 1 笔。如果存在,那么它需要 奇度点/2 笔。

       一种为含奇数点的  一种为只含偶数点的 
      对于含奇数点的     笔画数=奇数点个数/2  
     对于只含偶数点的   存在欧拉回路  笔画数=1 
    对于整张图  则  ans=总奇数点/2+只含偶数点的集合个数 

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int fa[100005],way[100005],mark[100005];
int n,m,ans;
void init()
{
    for(int i=0;i<=n;i++)
    {
        fa[i]=i;
        way[i]=0;
        mark[i]=0;
    }
}
int find(int x)
{
    if(fa[x]!=x)
        return fa[x]=find(fa[x]);
    return fa[x];
}
int add(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y)
    {
        fa[x]=y;
    }
}
void solve()
{
    int i,r;
    ans=0;
    for(i=1;i<=n;i++)
    {
        if(way[i]%2==1)
        {
            r=find(i);
            mark[r]=1;
            ans++;
        }
    }
    ans/=2;
    for(i=1;i<=n;i++)
    {
        if(way[i]>0)
        {
            r=find(i);
            if(mark[r]==0&&i==r)
            {
                ans++;
            }
        }
    }
}
int main()
{
    int i,j,t,l,r;
    while(~scanf("%d%d",&n,&m))
    {
        init();
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&l,&r);
            way[l]++;
            way[r]++;
            add(l,r);
        }
        solve();
        printf("%d\n",ans);
    }
    return 0;
}

你可能感兴趣的:(hdu 3018 欧拉回路)