POJ 2299 Ultra-QuickSort


  
  
  
  

Description

POJ 2299 Ultra-QuickSort_第1张图片In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence  9 1 0 5 4 , Ultra-QuickSort produces the output  0 1 4 5 9 . Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
题目大意:优化的冒泡排序,从小到大排序,就是找到一次没有交换时BREAK,问我们至少交换多少次冒泡排序可完成。
思路:因为每次交换的都是左边的数大于右边的数,所以,我们需要求出有多少逆数对即可。可以利用归并排序求解。
LANGUAGE:C
CODE:
#include<iostream>
#include<cstdlib>
#include<cstdio>
using namespace std;
int a[500005],c[500005];
long long cnt;
void mergesort(int left,int right)
{
    int mid,i,j,tmp;
    if(right>left+1)
    {
        mid=(left+right)/2;
        mergesort(left,mid);
        mergesort(mid,right);
        tmp=left;
        for(i=left,j=mid;i<mid&&j<right;)
        {
            if(a[i]>a[j])
            {
                c[tmp++]=a[j++];
                cnt+=mid-i;
            }
            else c[tmp++]=a[i++];
        }
        if(j<right)for(;j<right;++j)c[tmp++]=a[j];
        else for(;i<mid;++i)c[tmp++]=a[i];
        for(i=left;i<right;++i) a[i]=c[i];
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    int n;
    while(cin>>n,n)
    {
        cnt=0;
        for(int i=1;i<=n;i++)
        cin>>a[i];
        mergesort(1,n+1);
        cout<<cnt<<endl;
    }
    return 0;
}

复习时AC代码:
LANGUAGE:C++
CODE:
#include<iostream>

using namespace std;

long long  cnt;

void merge(int array[],int left,int mid,int right)
{
	int* temp=new int[right-left+1];
	int i,j,p;
	for(i=left,j=mid+1,p=0;i<=mid&&j<=right;p++)
	{
		if(array[i]<=array[j])temp[p]=array[i++];
		else temp[p]=array[j++],cnt+=(mid-i+1);
	}
	while(i<=mid)temp[p++]=array[i++];
	while(j<=right)temp[p++]=array[j++];
	for(i=left,p=0;i<=right;i++)array[i]=temp[p++];
	delete temp;
}

void mergesort(int array[],int left,int right)
{
	if(left==right)array[left]=array[right];
	else
	{
		int mid=(left+right)/2;
		mergesort(array,left,mid);
		mergesort(array,mid+1,right);
		merge(array,left,mid,right);
	}
}
int main()
{
    int n,array[500005];
    while(cin>>n,n)
    {
        cnt=0;
        for(int i=0;i<n;i++)
            cin>>array[i];
        mergesort(array,0,n-1);
            cout<<cnt<<endl;
    }
    return 0;
}


你可能感兴趣的:(POJ 2299 Ultra-QuickSort)