HDU2602_Bone Collector【01背包】

Bone Collector



Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31133    Accepted Submission(s): 12805

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
HDU2602_Bone Collector【01背包】_第1张图片


Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 
Sample Output
14
 
Author
Teddy
 
Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest


题目大意:有一个骨头收藏家,他有一个容量为V的容器来收藏骨头。现在有N个骨头

各个骨头的价值为v[i],各个骨头所占容量为w[i]。问他在容量为V的容器里,最多能

收藏总价值为多少的骨头?

思路:简单的01背包

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int v[1100],w[1100],dp[1100];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int N,V;
        scanf("%d%d",&N,&V);
        for(int i = 1; i <= N; i++)
            scanf("%d",&v[i]);
        for(int i = 1; i <= N; i++)
            scanf("%d",&w[i]);
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= N; i++)
        {
            for(int j = V; j >= w[i]; j--)
            {
                dp[j] = max(dp[j],dp[j-w[i]] + v[i]);
            }
        }
        printf("%d\n",dp[V]);
    }
    return 0;
}


你可能感兴趣的:(HDU2602_Bone Collector【01背包】)