POJ 3250-Bad Hair Day【栈】

Bad Hair Day
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 16017   Accepted: 5417

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ h≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows,  N
Lines 2..N+1: Line  i+1 contains a single integer that is the height of cow  i.

Output

Line 1: A single integer that is the sum of  c 1 through  cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stack>
using namespace std;
int map[100000];
stack<int >q;
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&map[i]);
		}
		q.push(map[1]);
		long long ans=0;
		for(int i=2;i<=n;i++)
		{
			while(!q.empty()&&q.top()<=map[i])
			{
				q.pop();	
			}
			ans+=q.size();
			q.push(map[i]);
		}
		printf("%lld\n",ans);
	}
	return 0;
}


你可能感兴趣的:(栈,poj)