Hat's Fibonacci
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7616 Accepted Submission(s): 2474
Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
Input
Each line will contain an integers. Process to end of file.
Output
For each case, output the result in a line.
Sample Input
Sample Output
4203968145672990846840663646
Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
import java.util.Scanner;
import java.math.BigInteger;
public class Main{
public static void main(String[] args){
Scanner cin = new Scanner(System.in);
BigInteger a, b, c, d;
BigInteger[] arr = new BigInteger[10000];
arr[1] = arr[2] = arr[3] = arr[4] = BigInteger.ONE;
arr[5] = BigInteger.valueOf(4);
for(int i = 6; i < 10000; ++i)
arr[i] = arr[i-1].add(arr[i-2]).add(arr[i-3]).add(arr[i-4]);
int n;
while(cin.hasNext()){
n = cin.nextInt();
System.out.println(arr[n]);
}
}
}