Poj 2823 (单调队列裸题)

Sliding Window
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 32104   Accepted: 9528
Case Time Limit: 5000MS

Description

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

POJ Monthly--2006.04.28, Ikki
求滑动区间的最大值和最小值。单调队列。以前的写法就不用了,还是现在写的好看。
#include<cstdio>
#include<iostream>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 1000000 + 5;
typedef pair<int,int> P;

deque<P> Q1;
deque<P> Q2;
int ans1[maxn],ans2[maxn];

int main(){
    int n,k,x;
    while(scanf("%d%d",&n,&k) != EOF){
        while(!Q1.empty()) Q1.pop_back();
        while(!Q2.empty()) Q2.pop_back();
        for(int i = 0;i < n;i++){
            scanf("%d",&x);
            while(!Q1.empty() && Q1.back().first >= x) Q1.pop_back();
            Q1.push_back(P(x,i));
            while(!Q1.empty() && Q1.front().second <= i-k) Q1.pop_front();
            ans1[i] = Q1.front().first;
            
            while(!Q2.empty() && Q2.back().first <= x) Q2.pop_back();
            Q2.push_back(P(x,i));
            while(!Q2.empty() && Q2.front().second <= i-k) Q2.pop_front();
            ans2[i] = Q2.front().first;
        }
        for(int i = k-1;i < n-1;i++) printf("%d ",ans1[i]);
        printf("%d\n",ans1[n-1]);
        for(int i = k-1;i < n-1;i++) printf("%d ",ans2[i]);
        printf("%d\n",ans2[n-1]);
    }
    return 0;
}


你可能感兴趣的:(Poj 2823 (单调队列裸题))