PAT (Advanced Level) Practise 1094 The Largest Generation (25)

1094. The Largest Generation (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
算一下树的那一层节点最多,直接dfs统计即可。
#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int mod = 1e9 + 7;
const int maxn = 1e5 + 10;
vector<int> t[maxn];
int n, m, x, y, z, cnt[maxn];

void dfs(int x, int dep)
{
	cnt[dep]++;
	for (int i = 0; i < t[x].size(); i++)
	{
		dfs(t[x][i], dep + 1);
	}
}

int main()
{
	scanf("%d%d", &n, &m);
	while (m--)
	{
		scanf("%d%d", &x, &y);
		while (y--) scanf("%d", &z), t[x].push_back(z);
	}
	dfs(1, 1);
	int now = 1;
	for (int i = 1; i <= n; i++)
	{
		if (cnt[i] > cnt[now]) now = i;
	}
	printf("%d %d\n", cnt[now], now);
	return 0;
}



你可能感兴趣的:(pat)