HDOJ题目地址:传送门
ACMer
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4646 Accepted Submission(s): 2164
Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?
Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
Output
For each test case, output the minumal number of students in HDU.
Sample Input
Sample Output
题意:acmer的人数在P%和Q%之间,最少P%,最多Q%,要求最少有多少个acmer,因为一个数据是最多
一个是最少,所以两个数据的人数不能相同,而且P%一定少于Q%
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int main(){
int n,sum;
double a,b;
cin>>n;
while(n--){
cin>>a>>b;
sum=1;//总数
while(1){
if((int)(a*sum/100)<(int)(b*sum/100)){
break;
}
sum++;
}
cout<<sum<<endl;
}
}