nyoj1253 Turing equation(第七届河南省程序设计大赛)

Turing equation

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述
The fight goes on, whether to store  numbers starting with their most significant digit or their least  significant digit. Sometimes  this  is also called  the  "Endian War". The battleground  dates far back into the early days of computer  science. Joe Stoy,  in his (by the way excellent)  book  "Denotational Semantics", tells following story:
"The decision  which way round the digits run is,  of course, mathematically trivial. Indeed,  one early British computer  had numbers running from right to left (because the  spot on an oscilloscope tube  runs from left to right, but  in serial logic the least significant digits are dealt with first). Turing used to mystify audiences at public lectures when, quite by accident, he would slip into this mode even for decimal arithmetic, and write  things  like 73+42=16.  The next version of  the machine was  made  more conventional simply  by crossing the x-deflection wires:  this,  however, worried the engineers, whose waveforms  were all backwards. That problem was in turn solved by providing a little window so that the engineers (who tended to be behind the computer anyway) could view the oscilloscope screen from the back.

You will play the role of the audience and judge on the truth value of Turing's equations.

输入
The input contains several test cases. Each specifies on a single line a Turing equation. A Turing equation has the form "a+b=c", where a, b, c are numbers made up of the digits 0,...,9. Each number will consist of at most 7 digits. This includes possible leading or trailing zeros. The equation "0+0=0" will finish the input and has to be processed, too. The equations will not contain any spaces.
输出
For each test case generate a line containing the word "TRUE" or the word "FALSE", if the equation is true or false, respectively, in Turing's interpretation, i.e. the numbers being read backwards.
样例输入
73+42=16
5+8=13
0001000+000200=00030
0+0=0
样例输出
TRUE
FALSE
TRUE
来源
第七届河南省程序设计大赛
上传者
516108736

和正常的两个数想加相反 。 反着存贮就好了

 
#include <stdio.h>
#include <string.h>
int main()
{
	char str[50];
	while(~scanf("%s",str))
	{
		if(strcmp(str,"0+0=0")==0)
		break;
		int a[3];
		int len=strlen(str);
		int t=0,sum=0;
		for(int i=len-1;i>=0;i--)
		{
			if(str[i]=='='||str[i]=='+')
			{
				a[t]=sum;
				t++;
				sum=0;
				continue;
			}
			sum=sum*10+str[i]-'0';
		}
		a[2]=sum;
		if(a[2]+a[1]==a[0])
		puts("TRUE");
		else
		puts("FALSE");
	}
}        


你可能感兴趣的:(nyoj,nyoj1253,1253)