POJ-2096-Collecting Bugs【概率dp】

POJ-2096-Collecting Bugs

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria — Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It’s important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan’s opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan’s work) required to name the program disgusting.
Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).
Output

Output the expectation of the Ivan’s working days needed to call the program disgusting, accurate to 4 digits after the decimal point.
Sample Input

1 2
Sample Output

3.0000

题目大意:每天查一个BUG,一共要查n种BUG,有s个子系统,而且每个子系统至少有一个 bug,求数学期望,多少天能查完。

题目链接:POJ 2096

题目思路:首先给定dp[i][j]的含义:它表示在已经找到属于j个系统的i个bug时的期望值,也就是还需要多少天才能完成任务。这样的话就有dp[n][s] = 0;那么我们要求的就是dp[0][0].

可以知道存在这四种状态:

            dp[i+1][j+1]发现一个bug属于新的一种bug和新的一个子系统 p1 = (n-i)*(s-j)/(n*s)
            dp[i][j]    发现一个bug属于已经找到的i种bug和j个子系统中 p4 = i*j/(n*s);
            dp[i+1][j]  发现一个bug属于新的一种bug,但属于已经找到的j种子系统 p2 = (n-i)*j/(n*s);
            dp[i][j+1]  发现一个bug属于已经找到的i种bug,但属于新的子系统 p3 = i*(s-j)/(n*s);

所以有公式:dp[i][j] = p1 * (dp[i+1][j+1] + 1) + p2 * (dp[i+1][j] + 1) + p3 * (dp[i][j+1] + 1) + p4 * (dp[i][j]+1);//公式中的+1代表本次的操作,即发现一个bug增加的一天

以下是代码:

#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;
double n,s;
double dp[1005][1005] = {0};  
int main(){ 
    while(cin >> n >> s)
    {
        memset(dp,0,sizeof(dp));
        for (int i = n; i >= 0; i--)
        {
            for (int j = s; j >= 0; j--)
            {
                double sum = s * n - i * j;
                if (j == s && i == n)   continue;
                dp[i][j] = (dp[i][j] + 1) * i * j * 1.0 / sum;      
                dp[i][j] += (dp[i][j + 1] + 1)* i * (s - j) * 1.0 / sum;  
                dp[i][j] += (dp[i + 1][j + 1] + 1)*  (n - i) * (s - j) * 1.0 / sum;  
                dp[i][j] += (dp[i + 1][j] + 1)* (n - i) * j * 1.0 / sum;            
            // dp[i][j] = (dp[i][j + 1] * i *(s - j) + dp[i + 1][j + 1] * (n - i) * (s - j) + dp[i + 1][j] * (n - i) * j + n * s)/ (n * s - i * j); 综合上式
            }           
        }
        printf("%.4f\n",dp[0][0]);
    } 
    return 0;
}

你可能感兴趣的:(概率DP)