杭电 2001 计算两点间的距离

计算两点间的距离

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 121611    Accepted Submission(s): 46373


Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
 


 

Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
 


 

Output
对于每组输入数据,输出一行,结果保留两位小数。
 


 

Sample Input
   
   
   
   
0 0 0 1 0 1 1 0
 


 

Sample Output
   
   
   
   
1.00 1.41

 

注意:输入的时候要写%lf,否则乱码。另外,pow函数包含在math里,是平方的意思。pow(a,2)其中a为平方的数,2为次方。

#include<stdio.h>
#include<math.h>
int main(){
 double a[5];
 while(~scanf("%lf%lf%lf%lf",&a[0],&a[1],&a[2],&a[3])){
  a[4]=pow(a[3]-a[1],2)+pow(a[2]-a[0],2);
  a[4]=sqrt(a[4]);
  printf("%.2f\n",a[4]);
 }
 return 0;
}

你可能感兴趣的:(杭电 2001 计算两点间的距离)