ZOJ-3333-Guess the Price【7th浙江省赛】

ZOJ-3333-Guess the Price

                Time Limit: 1 Second      Memory Limit: 32768 KB

In the television program “Shopping Street” of CCTV-2, two people, A and B are guessing price of a given item. You are asked to decide whose price is closer to the real price.

Input

There are multiple test cases. The first line of input is an integer T (T <= 10) indicating the number of test cases.

Each case contains three integers in one line: P, PA, PB (0 <= PA, PB <= P <= 100, PA != PB), indicating the real price, the price A guesses and the price B guesses.

Output

For each case, output “A” or “B” according to whose price is closer to the real price.

Sample Input
3
10 8 7
20 20 19
100 9 50

Sample Output
A
A
B

题目链接:ZOJ-3333

题目思路:水题

以下是代码:

#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;

int main(){
    int t;
    cin >> t;
    while(t--)
    {
        int p,a,b;
        cin >> p >> a >> b;
        a = abs(p - a);
        b = abs(p - b);
        if (a < b) cout << "A\n";
        else cout << "B\n";
    }
    return 0;
}

你可能感兴趣的:(ZOJ,3333)