KMP求最长连续重复字串——POJ 1961

对应POJ题目:点击打开链接

M - Period
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Submit  Status

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 ≤ N ≤ 1 000 000) � the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output �Test case #� and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:对于给定字符串的每个前缀,判断是否是循环字符串,是的话就输出前缀个数和重复次数;

如  aabaabaabaab 的前缀aabaabaab 有9个字符,周期为3,故重复次数为3


思路:实在是没有留意到可以这样用KMP。还是那9个字符,next[9] = 6,表示在前9个字符中,最多有前6个字符跟后6个字符相同,即next数组保存的是当前字符串的最长公共前后缀,而对于一个连续重复字符串在next数组中有这样的关系::           ————--

          a a b a a b a a b           这里是next[j] = k, 这样用j - k  就得到循环串的周期,再用 j / (j - k) 就是重复次数

          ————--


#include<stdio.h>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
#define ms(x,y) memset(x,y,sizeof(x))
const int MAXN=1000000+10;
const int INF=1<<30;
using namespace std;
int next[MAXN];
char str[MAXN];

void Getnext()
{
	int j = 0, k = -1;
	next[0] = -1;
	int len = strlen(str);
	while(j < len)
	{
		if(-1 == k || str[j] == str[k]){
			j++; k++;
			if(0 == j%(j-k) && j/(j-k)>1)
				printf("%d %d\n", j, j/(j-k));
			next[j] = k;
		}
		else k = next[k];
	}
}

int main()
{
	//freopen("in.txt","r",stdin);
	int n, w = 0;;
	while(scanf("%d", &n), n)
	{
		scanf("%s", str);
		printf("Test case #%d\n", ++w);
		Getnext();
		printf("\n");
	}
	return 0;
}



你可能感兴趣的:(KMP求最长连续重复字串——POJ 1961)