poj1013--Counterfeit Dollar

Counterfeit Dollar
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 38626   Accepted: 12338

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 

Source

East Central North America 1998
有12枚硬币其中一枚是假币,肯能轻也可能重,在三次比较中判断哪个是假币,并且判断轻重,
up  右轻左重 down 右重左轻 even 平衡
如果是平衡 那么比较中的硬币都是真的
如果不平衡,那么所有的硬币都可能要怀疑   如果重那么+1  如果轻-1 , 最后统计怀疑的程度
#include <stdio.h>
#include <string.h>
#include <math.h>
int main()
{
    int p[12] , q[12];
    char s1[10] , s2[10] , s3[10] ;
    int t ;
    scanf("%d", &t);
    while(t--)
    {
        int s = 3 ;
        memset(p,0,sizeof(p));
        memset(q,0,sizeof(q));
        while(s--)
        {
            scanf("%s %s %s", s1, s2 , s3);
            if(!strcmp(s3,"up"))
            {
                int i ;
                for(i = 0 ; s1[i] != '\0' ; i++)
                    p[ s1[i]-'A' ]++ ;
                for(i = 0 ; s2[i] != '\0' ; i++)
                    p[ s2[i]-'A' ]-- ;
            }
            else if(!strcmp(s3,"down"))
            {
                int i ;
                for(i = 0 ; s2[i] != '\0' ; i++)
                    p[ s2[i]-'A' ]++ ;
                for(i = 0 ; s1[i] != '\0' ; i++)
                    p[ s1[i]-'A' ]-- ;
            }
            else
            {
                int i ;
                for(i = 0 ; s1[i] != '\0' ; i++)
                    q[ s1[i]-'A' ] = 1 ;
                for(i = 0 ; s2[i] != '\0' ; i++)
                    q[ s2[i]-'A' ] = 1 ;
            }
        }
        int k , flag = 0 , i ;
        for(i = 0 ; i < 12 ; i++)
            if(fabs(flag) < fabs(p[i]) && q[i] == 0)
        {
            flag = p[i] ;
            k = i ;
        }
        if(p[k] < 0 )
        {
            printf("%c is the counterfeit coin and it is light.\n", k+'A');
        }
        else
            printf("%c is the counterfeit coin and it is heavy.\n", k+'A');
    }
    return 0;
}


你可能感兴趣的:(poj1013--Counterfeit Dollar)