2013秋13级预备队集训练习3 --E - The ? 1 ? 2 ? ... ? n = k problem

 The ? 1 ? 2 ? ... ? n = k problem 

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701
#include<stdio.h>
int main()
{
    int i , n , j , sum , k ;
    scanf("%d", &n);
    for(i = 1 ; i <= n ; i++)
    {
        scanf("%d", &k);
        if(k<0)
        {
            sum = 0;
            for(j = -1 ; ; j--)
            {
                sum = sum + j ;
                if(sum == k || (sum < k && (sum-k)%2==0 ))
                    {
                        printf("%d\n", -j);
                        break;
                    }
            }
        }
        else if(k > 0)
        {
            sum = 0;
            for(j = 1 ; ; j++)
            {
                sum = sum + j;
                if(sum ==k || (sum > k && (sum-k)%2==0 ) )
                {
                    printf("%d\n", j);
                    break;
                }
            }
        }
        else
            printf("3\n");
        if(i!=n)
            printf("\n");
    }
    return 0;
}

你可能感兴趣的:(2013秋13级预备队集训练习3 --E - The ? 1 ? 2 ? ... ? n = k problem)