2013秋13级预备队集训练习1 E - Kindergarten Counting Game


 Kindergarten Counting Game 

Everybody sit down in a circle. Ok. Listen to me carefully.

``Woooooo, you scwewy wabbit!''

Now, could someone tell me how many words I just said?

Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).

Your program should output a word count for each line of input. Each word count should be printed on a separate line.

Sample Input

Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...

Sample Output

2
7
10
9
#include<stdio.h>
#include<string.h>
int main()
{
	int i , flag , count ;
	char str[10000];
	while(gets(str)!=NULL)
	{
		flag = 0 ; count = 0 ;
		for(i = 0 ; str[i] != '\0' ; i++)
		{
			if((str[i] >= 'a' && str[i]<= 'z') || (str[i] >= 'A' && str[i]<= 'Z'))
			{
				if(flag == 0)
				{
					count++;
					flag = 1;
				}
			}
			else
				flag=0;
		}
		printf("%d\n", count);
	}
	return 0 ;
}


 

你可能感兴趣的:(2013秋13级预备队集训练习1 E - Kindergarten Counting Game)