jobdu 5 字符串内排序

题目描述:

输入一个字符串,长度小于等于200,然后将输出按字符顺序升序排序后的字符串。

输入:

测试数据有多组,输入字符串。

输出:

对于每组输入,输出处理后的结果。

样例输入:
bacd

样例输出:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main ()
{
	char buf[210];
	while(scanf ("%s",buf) != EOF)
	{
		int len = strlen(buf);
		sort (buf,buf + len);
		for (int i = 0;i < len;i ++)
			printf ("%c",buf[i]);
		printf ("\n");
	}
	return 0;
}


abcd
code1:
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
	char s[210];
	while(cin>>s)
	{
		int len=strlen(s);
		sort(s,s+len);
		cout<<s<<endl;
	}
	return 0;
}

code2:
#include <stdio.h>
#include <string.h>
int main()
{
	int a[26]={0};
	char s[201];
	while(scanf("%s",s)!=EOF)
	{
		int len=strlen(s);
		for(int i=0;i<len;i++)
			a[s[i]-'a']++;
		for(int j=0;j<26;j++)
		{
			while(a[j]--)
				putchar(j+'a');
		}
		printf("\n");
	}
	return 0;
}

你可能感兴趣的:(jobdu 5 字符串内排序)