HUNAM 10493

 
Factorials Again
Time Limit: 2000ms, Special Time Limit:5000ms, Memory Limit:32768KB
Total submit users: 293, Accepted users: 243
Problem 10493 : No special judgement
Problem description
The factorial of an integer N, written N!, is the product of all the integers from 1 through N inclusive. The factorial quickly becomes very large: 13! is too large to store in a 32-bit integer on most computers, and 70! is too large for most floating-point variables. Your task is to find the rightmost non-zero digit of n!. For example, 5! = 1 * 2 * 3 * 4 * 5 = 120, so the rightmost non-zero digit of 5! is 2. Likewise, 7! = 1 * 2 * 3 * 4 * 5 * 6 * 7 = 5040, so the rightmost non-zero digit of 7! is 4.
Input
There are multiple test cases. Each contains A single positive integer N no larger than 10,000 in a single line.

Input ends with a zero and this line should not be processed.
Output
A single line containing but a single digit: the right most non-zero digit of N! .
Sample Input
7
0
Sample Output
4
 
 
代码:注意进位问题,不能只取最后一位
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int n;
int main()
{
 int sum;
 int i;
 while(scanf("%d",&n)!=EOF)
 {
  if(n==0) break;
  sum=1;
  for(i=2;i<=n;i++)
  {
   sum*=i;
   if(sum%10==0)
   {
    while(sum%10==0)
     sum/=10;
   }
   if(sum>=10000)
   {
    sum%=10000;
   }
  }
  while(sum%10==0)
  {
   sum/=10;
  }
  printf("%d\n",sum%10);
 }
 return 0;
}



你可能感兴趣的:(Integer,input,each,output)