Input
There are only one case, including two lines, the fist line only contain one integer N, stands for the amount of raom digits . The second line contains N integers, stand for random digits (students number).
Output
There are 2 lines here, too. The first line contains one integer M. M means the different random digits’ amount. The second line contains M Integer separated by space, stand for the different integers in order.
Sample Input
10
20 40 32 67 40 20 89 300 400 15
Sample Output
8
15 20 32 40 67 89 300 400
Hint
20 and 40 only can left one。
<set>
思路:set默认的是升序,若要使其降序,则写个重载函数,重载函数我还不会写呢
#include<iostream>
#include<set>
using namespace std;
int main()
{
int i,j=0,n,a[105];
cin>>n;
for(i=0;i<n;i++)
cin>>a[i];
set<int>b;
b.insert(a,a+n);
set<int>::iterator it;
for(it=b.begin();it!=b.end();it++)
j++;
cout<<j<<endl;
for(it=b.begin();it!=b.end();it++)
cout<<*it<<' ';
return 0;
}