Largest Rectangle in a Histogram(单调栈) 分类: 数据结构 2015-07-07 23:23 2人阅读 评论(0) 收藏

Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint
Huge input, scanf is recommended.

Difficulty:单调栈:栈内的元素,按照某种方式排序下(单调递增或者单调递减) 如果新入栈的元素破坏了单调性,就弹出栈内元素,直到满足单调性
模板:
int top=0,s[maxn];
for(int i=1;i<=n;i++)
{while(top&&h[s[top]]>=h[i])//根据改变大于号小于号来改变单调性。
{--top;}//出栈,一般在while这重循环里添加东西去满足题意。
s[++top]=i;}//入栈

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cstdlib>
#include<algorithm>
using namespace std;
long long h[100006];
int  s[100006];
long long area[100006];
int L[100006];
int R[100006];
int n;
long long ans;
bool cmp( int a, int c)
{
    return  a>c;

}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        int top=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&h[i]);
            while(top&&h[s[top]]>=h[i])
                --top;
            L[i]=(top==0?1:s[top]+1);
            s[++top]=i;
        }
        for(int i=1;i<=n;i++)
        //printf("%d ",L[i]);printf("\n");
        top=0;
        for(int i=n;i>=1;i--)
        {while(top&&h[s[top]]>=h[i])
               --top;
            R[i]=(top==0?n:s[top]-1);
            s[++top]=i;
        }
        ans=-1;
        //for(int i=1;i<=n;i++)
        //printf("%d ",R[i]);}
        for(int i=1;i<=n;i++)
        {area[i]=h[i]*(R[i]-L[i]+1);
        //sort(area+1,area+n+1,cmp);
        if(ans<area[i])
        ans=area[i];}
        printf("%lld\n",ans);}
        return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

你可能感兴趣的:(数据结构)