Ekka Dokka -- 乘积奇数最大偶数最小

Ekka and his friend Dokka decided to buy a cake. They both love cakes and that's why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output

For each case, print the case number first. After that print "Impossible" if they can't buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input

3

10

5

12

Sample Output

Case 1: 5 2

Case 2: Impossible

Case 3: 3 4

分析:题目求解的是如果一个数可以被写成一个人奇数和偶数的乘积,并且偶数要求是最小的,如果存在则输出否则输出不可能

import java.util.*;
 public class Main{
    static Scanner in=new Scanner(System.in);
    public static void main(String args[]){ 
        int k=in.nextInt();  
        int ca = 0;
        while(k-->0){	
        	
        	ca++;
        long w = in.nextLong();
        if(w%2!=0){
        	System.out.println("Case "+ca+": Impossible"); 
        }
        else{
        long odd = 1,even;
        for(even=2;even <= w;even+=2)  
            if(w%even==0){  
            	odd=w/even;  
                if(odd%2!=0)  
                   break;  
            }
        System.out.println("Case "+ca+": "+odd+" "+even); 
        }
      }
    }
}

既然偶数要求最小,不如直接从最小偶数开始,这样才会不超时,即使 for(odd=w-1,odd<=w;odd-=2)也会超时的。。

奇数一定不可以,一个偶数可以写成一奇一偶或者两偶,而一个奇数只能写成两个奇数的乘积

你可能感兴趣的:(vjudge练习)