手贱,提交错了两个顺序,估计gg了
第一题:
我坑爹的竟然想到了用海伦公式,算出来24.92708569439206 唉,直接减去小的不就完事了啊`````
答案:8x8-(8x4)/2-4x6/2-8x2/2=28
第二题:
立方变自身
观察下面的现象,某个数字的立方,按位累加仍然等于自身。
1^3 = 1
8^3 = 512 5+1+2=8
17^3 = 4913 4+9+1+3=17
...
请你计算包括1,8,17在内,符合这个性质的正整数一共有多少个?
应该是语言入门题目,
public class Main {
public static void solve(){
}
static long N,M;
static long [] num = null;
public static void main(String[] args) {
long ans = 0;
for(long n = 1;n<10000;n++){
long tot = n*n*n;
long cmp = 0;
long t = tot;
while(t!=0){
cmp +=t%10;
t /=10;
}
if(cmp == n){
ans++;
System.out.println(n);
}
}
System.out.println("answer:"+ans);
}
}
//1
//8
//17
//18
//26
//27
//answer:6
三羊献瑞
观察下面的加法算式:
祥 瑞 生 辉
+ 三 羊 献 瑞
-------------------
三 羊 生 瑞 气
其中,相同的汉字代表相同的数字,不同的汉字代表不同的数字。
请你填写“三羊献瑞”所代表的4位数字(答案唯一)
这个就一通乱搞吧.
9 5 6 7
1 0 8 5
1 0 6 5 2
第四题:
import java.util.Vector;
public class Main {
// 循环节长度
//
// 两个整数做除法,有时会产生循环小数,其循环部分称为:循环节。
// 比如,11/13=6=>0.846153846153..... 其循环节为[846153] 共有6位。
// 下面的方法,可以求出循环节的长度。
//
// 请仔细阅读代码,并填写划线部分缺少的代码。
public static int f(int n, int m)
{
n = n % m;
Vector v = new Vector();
for(;;)
{
v.add(n);
n *= 10;
n = n % m;
if(n==0) return 0;
if(v.indexOf(n)>=0) return v.size()-v.indexOf(n) ; //填空
}
}
//注意,只能填写缺少的部分,不要重复抄写已有代码。不要填写任何多余的文字。
public static void main(String[] args) {
System.out.println(f(11,13));
System.out.println(f(11,17));
}
}
//
//九数组分数
//
//1,2,3...9 这九个数字组成一个分数,其值恰好为1/3,如何组法?
//
//下面的程序实现了该功能,请填写划线部分缺失的代码。
public class Main
{
public static void test(int[] x)
{
int a = x[0]*1000 + x[1]*100 + x[2]*10 + x[3];
int b = x[4]*10000 + x[5]*1000 + x[6]*100 + x[7]*10 + x[8];
if(a*3==b) System.out.println(a + " " + b);
}
public static void f(int[] x, int k)
{
if(k>=x.length){
test(x);
return;
}
for(int i=k; i
这个就是测试一下就OK了 答案: 16
//加法变乘法
//
//我们都知道:1+2+3+ ... + 49 = 1225
//现在要求你把其中两个不相邻的加号变成乘号,使得结果为2015
//
//比如:
//1+2+3+...+10*11+12+...+27*28+29+...+49 = 2015
//就是符合要求的答案。
//
//请你寻找另外一个可能的答案,并把位置靠前的那个乘号左边的数字提交(对于示例,就是提交10)。
//
//注意:需要你提交的是一个整数,不要填写任何多余的内容。
import java.util.Arrays;
import java.util.Vector;
public class Main {
public static void solve(){
}
static long N,M;
static long [] num = null;
public static void main(String[] args) {
int pre = 1225;
for(int p = 1;p<47;p++){
for(int pp = p+2;pp<49;pp++){
int now = pre ;
now -= p+p+1;
now -= pp+pp+1;
now += p*(p+1);
now += pp*(pp+1);
if(now==2015)
System.out.println(p+" "+ pp);
}
}
}
}
第七题:
直接dp就解决,但是考试的时候看错题目了,...............................................
import java.util.Arrays;
import java.util.Scanner;
public class Main {
static int []num = new int[170];
static int ans = 0;
public static void main(String[] args) {
int [][]dp = new int[14][14];
dp[0][0]=1;
for(int i = 1;i<14;i++)
for(int j = 0;j<14;j++)
for(int k = 0;k<5;k++)
if(j+k<=13)
dp[i][j+k] +=dp[i-1][j];
System.out.println(dp[13][13]);
}
}
//3598180
第八题:
注意每次计算得到落单的瓶盖
//
//饮料换购
//
//乐羊羊饮料厂正在举办一次促销优惠活动。乐羊羊C型饮料,凭3个瓶盖可以再换一瓶C型饮料,并且可以一直循环下去,但不允许赊账。
//
//请你计算一下,如果小明不浪费瓶盖,尽量地参加活动,那么,对于他初始买入的n瓶饮料,最后他一共能得到多少瓶饮料。
//
//输入:一个整数n,表示开始购买的饮料数量(0=3){
n = t/3+1;
mod = (t%3+mod)-3;
}else{
n = t/3;
mod += t%3;
}
}
System.out.println(ans);
}
}
递推,还得用矩阵加速吧,JAVA写的太难受就没写,直接裸的
import java.util.Arrays;
import java.util.Scanner;
public class Main {
static int MOD = (int) (1e9+7);
public static void main(String[] args) {
int [][]ar = new int[40][40];
int []mm = {0,4,5,6,1,2,3};
long [][]dp = new long[2][7];
Scanner in = new Scanner(System.in);
int n = in.nextInt();
int m = in.nextInt();
for(int i = 0;i
LCA问题.题意和样例不对应,怪怪的.....铁定超时.
//生命之树
//
//在X森林里,上帝创建了生命之树。
//
//他给每棵树的每个节点(叶子也称为一个节点)上,都标了一个整数,代表这个点的和谐值。
//上帝要在这棵树内选出一个非空节点集S,使得对于S中的任意两个点a,b,都存在一个点列 {a, v1, v2, ..., vk, b} 使得这个点列中的每个点都是S里面的元素,且序列中相邻两个点间有一条边相连。
//
//在这个前提下,上帝要使得S中的点所对应的整数的和尽量大。
//这个最大的和就是上帝给生命之树的评分。
//
//经过atm的努力,他已经知道了上帝给每棵树上每个节点上的整数。但是由于 atm 不擅长计算,他不知道怎样有效的求评分。他需要你为他写一个程序来计算一棵树的分数。
//
//「输入格式」
//第一行一个整数 n 表示这棵树有 n 个节点。
//第二行 n 个整数,依次表示每个节点的评分。
//接下来 n-1 行,每行 2 个整数 u, v,表示存在一条 u 到 v 的边。由于这是一棵树,所以是不存在环的。
//
//「输出格式」
//输出一行一个数,表示上帝给这棵树的分数。
//
//「样例输入」
//5
//1 -2 -3 4 5
//4 2
//3 1
//1 2
//2 5
//
//「样例输出」
//8
//
//「数据范围」
//对于 30% 的数据,n <= 10
//对于 100% 的数据,0 < n <= 10^5, 每个节点的评分的绝对值不超过 10^6 。
//
//资源约定:
//峰值内存消耗(含虚拟机) < 256M
//CPU消耗 < 3000ms
import java.util.Arrays;
import java.util.Scanner;
public class Main {
static int [] head1 = new int [100010];
static int [] head2 = new int [100010];
static int [] node = new int [100010];
static Edge []edge1 = new Edge[300010];
static Edge []edge2 = new Edge[300010];
static int [] degree = new int [100010];
static int [] fa = new int [100010];
static int tot1 = 0,tot2 = 0;
static int Node;
static long [] max = new long[100010];
static long ans = Long.MIN_VALUE;
static void add1(int u,int v){
edge1[tot1].u = u;
edge1[tot1].v = v;
edge1[tot1].nxt = head1[u];
head1[u] = tot1++;
}
static void add2(int u,int v){
edge2[tot2].u = u;
edge2[tot2].v = v;
edge2[tot2].nxt = head2[u];
head2[u] = tot2++;
}
static void dfs(int u,int par,long nn){
max[u] = nn;
fa[u] = u;
for(int i = head1[u];i!=-1;i=edge1[i].nxt){
int v = edge1[i].v;
if(v==par) continue;
dfs(v,u,nn+node[v]);
fa[v] = u;
}
for(int i = head2[u];i!=-1;i=edge2[i].nxt){
int v = edge2[i].v;
if(max[v]!=Long.MAX_VALUE){
ans = Math.max(ans, max[v]+max[u]-max[parent(v)]);
}
}
}
static int parent(int x){
if(fa[x]==-1 || fa[x]==x)
return x;
return fa[x] = parent(fa[x]);
}
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
Node = in.nextInt();
for(int i = 0;i