hdu 2147 kiki's game(博弈论)

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 7594    Accepted Submission(s): 4507


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0
 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
 
   
5 3 5 4 6 6 0 0
 

Sample Output
 
   
What a pity! Wonderful! Wonderful!
 

Author
月野兔
题目分析:
因为行和列分别要走n-1步和m-1步,所以只要保证剩下的步数有一个是二的倍数即可保证不输,那么也就是当前点必须存在至少一个奇数
所以就是n-1和m-1要至少存在一个奇数
#include"stdio.h"

int main( )
{
    int n,m;
    while(scanf("%d%d",&n,&m)&&(n!=0||m!=0))
    {
        if(n%2==0||m%2==0)
            printf("Wonderful!\n");
        else
            printf("What a pity!\n");
    }
    return 0;
}


你可能感兴趣的:(hdu 2147 kiki's game(博弈论))