HDU1496:Equations(二分)

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8166    Accepted Submission(s): 3354


Problem Description
Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
 
    
1 2 3 -4 1 1 1 1
 

Sample Output
 
    
39088 0
 

Author
LL
 

Source
“2006校园文化活动月”之“校庆杯”大学生程序设计竞赛暨杭州电子科技大学第四届大学生程序设计竞赛
题意:给定a,b,c,d,求在定义域内有多少种解。
# include 
# include 
# include 
using namespace std;
int x[10001], y[10001];
int main()
{
    int a, b, c, d;
    while(~scanf("%d%d%d%d",&a,&b,&c,&d))
    {
        if(a>0&&b>0&&c>0&&d>0 || a<0&&b<0&&c<0&&d<0)//全为负数的剪枝快1s多。
        {
            puts("0");
            continue;
        }
        int k=0;
        long long ans = 0;
        for(int i=1; i<=100; ++i)
            for(int j=1; j<=100; ++j)
            {
                x[k] = a*i*i+b*j*j;
                y[k++] = c*i*i+d*j*j;
            }
        sort(x, x+k);
        sort(y, y+k);
        for(int i=0; i>1;
                if(x[i]+y[mid]<0)
                    l = mid+1;
                else
                    r = mid;
            }
            if(x[i]+y[r] == 0)
            {
                ++tmp;
                for(int t=r-1; t>=0&&x[i]+y[t]==0; ++tmp,--t);
                for(int t=r+1; t



转载于:https://www.cnblogs.com/junior19/p/6729994.html

你可能感兴趣的:(HDU1496:Equations(二分))