2020-08-22

1074 Reversing Linked List (25分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.
Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
代码:
#include “cstdio”
#include “iostream”
#include “string”
#include “algorithm”
#include “vector”
#include “cstring”
#include “set”
#include “map”
#include “math.h”
#include “stack”
#include “queue”
using namespace std;
const int MAX = 0x3fffffff;
const int maxn = 100010;
struct Node {
int addr;
int value;
int next;
}sqlist[maxn];
int main(){
#ifdef ONLINE_JUDGE
#else
freopen(“sample.txt”, “r”, stdin);
#endif
int firstAddress, n, needReverseNode;
cin >> firstAddress >> n >> needReverseNode;
int temp;
for(int i = 0; i < n; i++){
scanf("%d", &temp);
sqlist[temp].addr = temp;
scanf("%d %d", &sqlist[temp].value, &sqlist[temp].next);
}
vector list_;
Node node = sqlist[firstAddress];
list_.push_back(node);
while(node.next != -1){
node = sqlist[node.next];
list_.push_back(node);
}
if(needReverseNode > list_.size()){
needReverseNode = list_.size();
}
int gap = list_.size() / needReverseNode;
int pos = 0;
for(int i = 0; i < gap; i++){
if(pos + needReverseNode > list_.size()){
needReverseNode = list_.size() - pos;
}
reverse(list_.begin() + pos, list_.begin() + pos + needReverseNode);
pos += needReverseNode;
}
for(int i = 0; i < list_.size(); i++){
if(i == list_.size() - 1){
printf("%05d %d -1\n", list_[i].addr, list_[i].value);
break;
}
printf("%05d %d %05d\n", list_[i].addr, list_[i].value, list_[i + 1].addr);
}
return 0;
}

你可能感兴趣的:(c++)