HDU 1556 Color the ball(树状数组)

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4258    Accepted Submission(s): 2285


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

 

Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

 

Sample Output
1 1 1 3 2 1
 

 

Author
8600
 

 

Source
 

 

Recommend
LL
 
 
 
此题比较有意思。是更新线段,查询点的。可以用线段树做,也可以用树状数组做。
更新的时候在左端点+1,右端点的下一个-1
查询点也就变成求和了。
/*

HDU 1556 Color the ball

树状数组

这题是插段求点。有点变化

但是是一样的。插线段的话就在线段左端点加1,在右端点后面减一。

这样求和得到的就是这个点的染色次数了。

*/

#include<stdio.h>

#include<iostream>

#include<string.h>

using namespace std;



const int MAXN=100010;

int c[MAXN];

int n;



int lowbit(int x)

{

    return x&(-x);

}

void add(int i,int val)

{

    while(i<=n)

    {

        c[i]+=val;

        i+=lowbit(i);

    }

}

int sum(int i)

{

    int s=0;

    while(i>0)

    {

        s+=c[i];

        i-=lowbit(i);

    }

    return s;

}

int main()

{

    int a,b;

    while(scanf("%d",&n),n)

    {

        memset(c,0,sizeof(c));

        for(int i=0;i<n;i++)

        {

            scanf("%d%d",&a,&b);

            add(a,1);

            add(b+1,-1);

        }

        for(int i=1;i<n;i++)

          printf("%d ",sum(i));

        printf("%d\n",sum(n));

    }

    return 0;

}

 

你可能感兴趣的:(color)