ZOJ 3662 Math Magic 第37届ACM/ICPC长春赛区H题(DP)

Math Magic

Time Limit: 3 Seconds      Memory Limit: 32768 KB

Yesterday, my teacher taught us about math: +, -, *, /, GCD, LCM... As you know, LCM (Least common multiple) of two positive numbers can be solved easily because of a * b = GCD (a, b) * LCM (a, b).

In class, I raised a new idea: "how to calculate the LCM of K numbers". It's also an easy problem indeed, which only cost me 1 minute to solve it. I raised my hand and told teacher about my outstanding algorithm. Teacher just smiled and smiled...

After class, my teacher gave me a new problem and he wanted me solve it in 1 minute, too. If we know three parameters N, M, K, and two equations:

1. SUM (A1, A2, ..., Ai, Ai+1,..., AK) = N
2. LCM (A1, A2, ..., Ai, Ai+1,..., AK) = M

Can you calculate how many kinds of solutions are there for Ai (Ai are all positive numbers). I began to roll cold sweat but teacher just smiled and smiled.

Can you solve this problem in 1 minute?

Input

There are multiple test cases.

Each test case contains three integers N, M, K. (1 ≤ N, M ≤ 1,000, 1 ≤ K ≤ 100)

Output

For each test case, output an integer indicating the number of solution modulo 1,000,000,007(1e9 + 7).

You can get more details in the sample and hint below.

Sample Input

4 2 2

3 2 2

Sample Output

1

2

Hint

The first test case: the only solution is (2, 2).

The second test case: the solution are (1, 2) and (2, 1).


Contest: The 2012 ACM-ICPC Asia Changchun Regional Contest

 

 

很水的DP,长春赛的时候竟然没有做出来。。。。。方向是写对了的,只是最后半个小时写的,很紧张。最后超时了。

需要注意些细节,一些初始化才不会超时。

预处理出LCM[1000][1000]来。

dp[now][i][j]表示当前状态下,和为i,LCM为j的解的个数。递推K次就出答案了。

#include<stdio.h>

#include<algorithm>

#include<string.h>

#include<iostream>

using namespace std;

const int MOD=1000000007;

int dp[2][1010][1010];



int num[1000];



int gcd(int a,int b)

{

    if(b==0)return a;

    return gcd(b,a%b);

}

int lcm(int a,int b)

{

    return a/gcd(a,b)*b;

}

int LCM[1010][1010];

int main()

{

    int n,m,k;

    for(int i=1;i<=1000;i++)

      for(int j=1;j<=1000;j++)

        LCM[i][j]=lcm(i,j);





    while(scanf("%d%d%d",&n,&m,&k)!=EOF)

    {

        int cnt=0;

        for(int i=1;i<=m;i++)

        {

            if(m%i==0)

               num[cnt++]=i;

        }

        int now=0;

        //memset(dp[now],0,sizeof(dp[now]));

        for(int i=0;i<=n;i++)

          for(int j=0;j<cnt;j++)

            dp[now][i][num[j]]=0;

        dp[now][0][1]=1;



        for(int t=1;t<=k;t++)

        {

            now^=1;

           // memset(dp[now],0,sizeof(dp[now]));

          for(int i=0;i<=n;i++)

            for(int j=0;j<cnt;j++)

              dp[now][i][num[j]]=0;

            for(int i=t-1;i<=n;i++)

              for(int j=0;j<cnt;j++)

              {

                  if(dp[now^1][i][num[j]]==0)continue;

                  for(int p=0;p<cnt;p++)

                  {

                      int x=i+num[p];

                      //int y=lcm(num[j],num[p]);

                      int y=LCM[num[j]][num[p]];

                      if(x>n||m%y!=0)continue;

                      dp[now][x][y]+=dp[now^1][i][num[j]];

                      dp[now][x][y]%=MOD;

                  }

              }

        }

        printf("%d\n",dp[now][n][m]);

    }

    return 0;

}

 

你可能感兴趣的:(Math)