【PAT】1092.To Buy or Not to Buy

【PAT】1092.To Buy or Not to Buy

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

Input Specification:
Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:
For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

题解

比较第2串字符串是不是第1串字符串的子集。如果是输出 Yes 和 2者之间的长度差,如果不是输出 No 和第 2 串里多出的元素数目。


一、ACM模式下InputStreamReader和BufferedReader的使用
二、OJ平台(牛客等)中Java的输入方法

思路:哈希表

package byx.leetcode.longest_univalue_path;

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.*;

//Hash
public class Main {
    public static void main(String[] args) throws IOException {
//        Scanner in = new Scanner(System.in);
//        String a = in.next();
//        String b = in.next();

        BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));//用BufferedReader替换Scanner流进行输入
        String a = bf.readLine();
        String b = bf.readLine();

        int[] counts = new int[122+1];//'z'是122
        for (char c : a.toCharArray()) {
            counts[c]++;
        }
        for (char c : b.toCharArray()) {
            counts[c]--;
        }

        int sum = 0;
        for (int count : counts) {
            if (count < 0) {
                sum += -count;
            }
        }

        if (sum > 0) {
            System.out.println("No " + sum);
        }
        else {
            System.out.println("Yes " + (a.length() - b.length()));
        }
    }
}

你可能感兴趣的:(Java相关,#,力扣及OJ,java,算法)